Buscar en este blog

3 de octubre de 2011

Verificando en Excel si un RFC tiene homoclave

En esta ocasión veremos como verificar que un RFC cuente con su homoclave que la mayoría de las veces en los reportes no cuenta con él, ya sea que el contribuyente no lo haya proporcionado o que el sistema no lo tenga.

Entremos en materia. Tenemos cuatro RFC de los cuales 2 no tienen su homoclave (realmente son los dos primeros a los cuales se le eliminó), en la celda C3 se creó la fórmula =LARGO(B2) la cual da el número de caracteres que contiene la celda B2.

En el caso de las personas física éstas tiene un RFC de 12 caracteres (ver celda C3) mientras que las personas morales tiene 13.
El siguiente paso es crear una fórmula en la celda D2: =SI(O(C2=13,C2=12),"OK","Error"). En esta fórmula utilizamos la función =SI junto con la función O que nos permite evaluar más de una opción.
Con éstos paso podemos ver que celdas cumplen con el criterio de la homoclave, para una mayor referencia puedes descargar el archivo más abajo.


Descargar el archivo en Excel

Espero haberte ayudado, envíame tus dudas por medio de las opiniones del blog.

Lo Último de mi Blog

LinkWithin

Related Posts with Thumbnails
¡¿Te gusta Capacitate?, recomiéndalo