17 de octubre de 2022

Uso de comodines en Excel 2

En este artículo veremos cómo utilizar la función SUMAR.SI utilizando el comodín de Interrogación (?)

En un artículo anterior vimos cómo utilizar el comodín de asterisco que nos permite reemplazar cualquier número de caracteres. En esta ocasión vamos a utilizar el comodín de signo de interrogación de cierre (?) que nos permite reemplazar tantos caracteres como signos usemos.

Descargar archivo en Excel....

Ejemplos

MID1234 = "MID????" (Son MID y 4 caracteres, los que sean)

MIDABCD ="MID????" (Son MID y 4 caracteres, los que sean)

MID1234 < > "MID??" (MID1234 es diferente a MID y 2 caracteres, los que sean)


Situación a solucionar

Tenemos una lista de datos donde podemos ver que tienen 3 letras y a su derecha 2 o más números. Nos solicitan la suma de los MID y 3 caracteres a la derecha, además de MID y 2 caracteres a la derecha

Solución


MID + 3 caracteres

=SUMAR.SI(B5:B20,"MID???",C5:C20), Excel buscará en el rango B5:B20 aquellas cadenas de caracteres que comiencen con MID y le sigan 3 caracteres, los que sean y sumará el valor del rango C5:C20 

MID + 2 caracteres

=SUMAR.SI(B5:B20,"MID??",C5:C20), Excel buscará en el rango B5:B20 aquellas cadenas de caracteres que comiencen con MID y le sigan 2 caracteres, los que sean y sumará el valor del rango C5:C20 

Nota. Los comodines se puede utilizar con otras funciones de Excel. 


12 de octubre de 2022

Uso de Comodines en Excel

 En este artículo veremos cómo utilizar la función SUMAR.SI utilizando el comodín de asterisco (*)

Descargar archivo en Excel...

Situación a solucionar

Tenemos una lista de teléfono modernos donde podemos ver los nombres y el número de unidades. Nos solicitan un resumen de unidades por marca pero podemos ver que los productos tienen el nombre de la marca junto con el modelos del teléfono. 

¿Cómo podemos hacer este resumen teniendo los productos de la manera mostrada?


Opción 1. Utilizando los comodines podemos solucionar este punto. 


En la celda F5 ponemos la siguiente función =SUMAR.SI($B$5:$B$20,"*Vivo*",C$5:C$20)
  1. La Función SUMAR.SI nos permite sumar una columna en base al criterio en otra columna y aquí podemos ver cómo utilizar la función SUMAR.SI
  2. $B$5:$B$20 este Argumento es el rango de los modelos y unidades
  3. "*Vivo*" Aquí estamos utilizando el comodín * (asterisco). Este comodín suple cualquier carácter antes y después de la palabra Vivo ("* y *"). Todo texto utilizado en una función debe estar entre comillas dobles. Excel va recorrer este rango y va a identificar aquellas celdas que cumplan que tienen la cadena Vivo, si se cumple Excel sumará el valor de la columna C$5:C$20
  4. C$5:C$20 Este argumento es la columna a sumar y solo la sumará si se cumple lo mencionado en el punto 3.
Opción 2 .- Utilizando comodines y el vínculo a la celda con el nombre



=SUMAR.SI($B$5:$B$20,"*"&H5&"*",$C$5:$C$20)
En este caso lo único que cambia es como utilizamos 2o. argumento. En vez de escribir "*Vivo*" ponemos lo siguiente "*"&H5&"*".

Los caracteres & nos permite tomar la palabra Vivo directamente de la celda mediante vínculo. Puedes ver este vínculo se encuentra entre comillas dobles.



 


15 de junio de 2021

Cómo eliminar celdas vacias en Excel

Cómo eliminar celdas vacias en Excel

En la siguiente imagen necesitamos eliminar las celdas vacias que están de color amarillo sin tener que eliminar la fila completa, en este artículo veremos cómo hacerlo


Pasos a seguir

1.- Seleccionamos el rango C3:E11

2.- Ahora hacemo clic en la tecla F5 para activar la aplicación de Ir a..


3.- Haz clic en el botón que dice Especial... con lo que tenemos las opciones de selección.


4.- Hacemos clic en la opción Celdas en blanco y clic en Aceptar con esto se leccionan solo las celdas en vacias.


5.- Hacemos clic sobre el botón de opciones del mouse y selecionamos la opción de Eliminar, y seguido seleccionamos Desplazar las celdas hacia arriba.




Trabajo Final


¿Necesitas aprender Excel Básico o Excel Avanzado?
Contáctame...

.