12 de octubre de 2022

Uso de Comodines en Excel

 En este artículo veremos cómo utilizar la función SUMAR.SI utilizando el comodín de asterisco (*)

Descargar archivo en Excel...

Situación a solucionar

Tenemos una lista de teléfono modernos donde podemos ver los nombres y el número de unidades. Nos solicitan un resumen de unidades por marca pero podemos ver que los productos tienen el nombre de la marca junto con el modelos del teléfono. 

¿Cómo podemos hacer este resumen teniendo los productos de la manera mostrada?


Opción 1. Utilizando los comodines podemos solucionar este punto. 


En la celda F5 ponemos la siguiente función =SUMAR.SI($B$5:$B$20,"*Vivo*",C$5:C$20)
  1. La Función SUMAR.SI nos permite sumar una columna en base al criterio en otra columna y aquí podemos ver cómo utilizar la función SUMAR.SI
  2. $B$5:$B$20 este Argumento es el rango de los modelos y unidades
  3. "*Vivo*" Aquí estamos utilizando el comodín * (asterisco). Este comodín suple cualquier carácter antes y después de la palabra Vivo ("* y *"). Todo texto utilizado en una función debe estar entre comillas dobles. Excel va recorrer este rango y va a identificar aquellas celdas que cumplan que tienen la cadena Vivo, si se cumple Excel sumará el valor de la columna C$5:C$20
  4. C$5:C$20 Este argumento es la columna a sumar y solo la sumará si se cumple lo mencionado en el punto 3.
Opción 2 .- Utilizando comodines y el vínculo a la celda con el nombre



=SUMAR.SI($B$5:$B$20,"*"&H5&"*",$C$5:$C$20)
En este caso lo único que cambia es como utilizamos 2o. argumento. En vez de escribir "*Vivo*" ponemos lo siguiente "*"&H5&"*".

Los caracteres & nos permite tomar la palabra Vivo directamente de la celda mediante vínculo. Puedes ver este vínculo se encuentra entre comillas dobles.



 


No hay comentarios.:

Publicar un comentario

Gracias por tu comentario.

.