17 de octubre de 2022

Uso de comodines en Excel 2

En este artículo veremos cómo utilizar la función SUMAR.SI utilizando el comodín de Interrogación (?)

En un artículo anterior vimos cómo utilizar el comodín de asterisco que nos permite reemplazar cualquier número de caracteres. En esta ocasión vamos a utilizar el comodín de signo de interrogación de cierre (?) que nos permite reemplazar tantos caracteres como signos usemos.

Descargar archivo en Excel....

Ejemplos

MID1234 = "MID????" (Son MID y 4 caracteres, los que sean)

MIDABCD ="MID????" (Son MID y 4 caracteres, los que sean)

MID1234 < > "MID??" (MID1234 es diferente a MID y 2 caracteres, los que sean)


Situación a solucionar

Tenemos una lista de datos donde podemos ver que tienen 3 letras y a su derecha 2 o más números. Nos solicitan la suma de los MID y 3 caracteres a la derecha, además de MID y 2 caracteres a la derecha

Solución


MID + 3 caracteres

=SUMAR.SI(B5:B20,"MID???",C5:C20), Excel buscará en el rango B5:B20 aquellas cadenas de caracteres que comiencen con MID y le sigan 3 caracteres, los que sean y sumará el valor del rango C5:C20 

MID + 2 caracteres

=SUMAR.SI(B5:B20,"MID??",C5:C20), Excel buscará en el rango B5:B20 aquellas cadenas de caracteres que comiencen con MID y le sigan 2 caracteres, los que sean y sumará el valor del rango C5:C20 

Nota. Los comodines se puede utilizar con otras funciones de Excel. 


No hay comentarios.:

Publicar un comentario

Gracias por tu comentario.

.