Páginas

Buscar en este blog

3 de octubre de 2011

Como evitar en Excel #¡DIV/0! al dividir entre cero

Cuando en Excel hacemos una división entre cero, éste nos arroja el siguiente resultado #¡DIV/0!, ésto se debe a que Microsoft Excel no acepta la división entre cero aunque todos sabemos que en nuestro trabajo de  cada día nos hemos visto en la necesidad de dividir entre cero.

Para solucionar este inconveniente necesitamos crear una fórmula utilizando la función =SI( ).
Supongamos que tenemos el siguiente caso (ver imagen).


Podemos ver que en la celda A2 tenemos un cero y que la fórmula en la celda C2 tiene una división utilizando la celda B2 y la celda con el cero antes mencionado lo cual arroja el resultado #¡DIV/0!

La solución
La solución para evitar que Excel nos arroje #¡DIV/0! es poner en la celda C2 la siguiente fórmula: =SI(A2=0,0,B2/A2), luego solo necesitamos copiarla en la celda de abajo.


Lo que hicimos fue decirle a Excel que Si la celda A2 contiene un número cero nos arroje un cero como respuesta, pero si no es cero le pedimos que nos arroje el resultado de la fórmula.


Espero haberlos ayudado, saludos y nos vemos la próxima semana.

LinkWithin

Related Posts with Thumbnails
¡¿Te gusta Capacitate?, recomiéndalo