Páginas

Buscar en este blog

5 de noviembre de 2012

Validación Personalizada en Excel


La validación de datos

En Excel es posible establecer restricciones sobre los datos que puede aceptar una celda. Esto quiere decir, que si queremos que una celda solo acepte números y además que se encuentren entre un rango de 100 a 500, podemos hacerlo mediante la opción de Validación.

Ver artículo de validación de datos


Caso práctico

En nuestro libro de Excel tenemos dos hojas, una llamada Total la cual suma los importes de una hoja de captura llamada ENE (depende del mes).

Puedes descargar el libro en el link al final de este artículo.

Se suman los datos, solo si corresponden a su departamento, ver fórmula de la imagen.

Validación en Excel
Hoja TOTAL

Explicación de la fórmula =SUMAR.SI del ejercicio.

 =SUMAR.SI(ENE!$B$2:$I$2,A3,ENE!$B$3:$I$3)
De la hoja ENE sumar los datos del rango B3:I3 de la hoja ENE solo si el rango B2:I2 (siempre de la hoja ENE) tiene el mismo dato que la celda A3 en la hoja Total.
Validación de datos en Excel
Hoja ENE

Que vamos a validar.

Ningún mes puede tener un total mayor a 100 mil (ver celda B15 hoja TOTAL). Cuando introducimos datos en las celdas validadas, (ver hoja ENE) automáticamente Excel arroja un aviso de que el total del Mes en la hoja Total se ha excedido el máximo establecido.

Como hacemos la validación, solución.

  • De la hoja Total seleccionamos la celda B11 y en el cuadro de nombres escribimos TotalPtoEne ver imagen.
Cuadro de nombres


  • De la hoja Total seleccionamos la celda B15 que contiene el importe máximo permitido. Escribimos en el cuadro de nombre la palabra TotalPto ver imagen.
Validación Excel

  • Ahora de la hoja ENE seleccionamos el rango de celdas B3:I3 y aplicamos la validación.
Validación de datos en Excel

Hacemos clic en Datos > Validación de datos para activar el cuadro de validación.

Excel validación

Establecemos un mensaje de Error.

Excel Validación

Finalmente hacemos clic en el botón de Aceptar y ya tenemos lista la validación de datos.












Lo Último de mi Blog

LinkWithin

Related Posts with Thumbnails
¡¿Te gusta Capacitate?, recomiéndalo