21 de abril de 2014

Función SI, Caso Práctico en Excel 2010

Como utilizar la función SI en un caso real.

En este artículo veremos un caso práctico de como utilizar la función SI en un caso real el cual se me presentó.

Presentación del caso.

Se desea obtener la suma total de los importes de Oct 2013 a Febrero 2014, para ello se crea una columna que contenga la suma de los meses de Octubre 2013 a Febrero 2014.


Consideraciones


  • Hay mas de 20 mil filas por lo que hacerlo a mano no sería factible
  • Hay tres ejercicios (2012 a 2104) en la lista de datos de la hoja de cálculo por lo que hay que tener cuidado de no tomar otros años que no sean los requeridos.

Solución.

La solución es utilizar la función SI de la siguiente manera:
=SI(A2=2013,SUMA(L2:N2),SI(A2=2014,SUMA(C2:D2),0))

Explicación de la función
Se hace la afirmación que la celda del año es igual a 2013 A2=2013, de ser verdad se aplica una suma a los meses de octubre a diciembre SUMA(L2:N2), de no ser verdad se vuelve a utiliza otro SI afirmando que la celda es igual a 2014 A2=2014, de ser verdad se suma las columnas que de los meses enero y febrero SUMA(C2:D2). Ahora si no es 2013 ni 2014 se pone cero, ver el último cero de la función.

Como en este caso nunca va a haber dos años iguales en la misma celda solo tendremos la suma de octubre a diciembre o de enero a febrero, con el cuidado de tener el año correcto en cualquiera de estos casos.

Si te gustó este artículo y te pareció de utilidad, te invitamos a suscribirte sin costo para que recibas los siguientes directamente en tu cuenta de correo. También te invito a dar clic en Me Gusta de Facebook y +1 de Google.

Lo Último de mi Blog

LinkWithin

Related Posts with Thumbnails
¡¿Te gusta Capacitate?, recomiéndalo