Buscar en este blog

LinkWithin

Related Posts with Thumbnails

13 de noviembre de 2019

Uso de la Función Indice

Veremos como utilizar la funcíón INDICE, COINCIDIR y el Formato Condicional de Fórmula

El usuario quiere que al seleccionar un Estado y un mes de Enero a Junio en la celda F2 se visualice el importe correspondiente al Estado y mes en cuestión.

Para ello utilicé la funcion INDICE la cual me devuelve el valor de una referencia de fila y columna en una matriz dada.

 Descargar el archivo en Excel desde este enlace



Solución (ver celda F2)
Sintaxis: INDICE(matriz; núm_fila; [núm_columna]) En forma de Matriz

=INDICE(C6:H37,COINCIDIR(C2,B6:B37,0),COINCIDIR(C3,C5:H5,0))

Matriz (obligatorio): En este caso es el rango C6:H37 el cual corresponde a todos los valores de las sucursales de los meses de enero a junio.

núm_fila (obligatorio) : Número de fila en la matriz (no la hoja) del valor que queremos.
COINCIDIR(C2,B6:B37,0) La función COINCIDIR devuelve la posición relativa de un valor buscado en una matriz, en este caso se desea saber que posición tiene el Estado (C2) en la lista de Estados (B6:B37), el cero quiere decir encontrar el primer valor que es exactamente igual que el valor_buscado.

[núm_columna] (opcional): Número de columna en la matriz (no la hoja) del valor que queremos.
COINCIDIR(C3,C5:H5,0) Lo mismo que en núm_fila pero esta vez se necesita la posición relativa del mes en la lista de meses C5:H5, el cero se utiliza para encontrar el primer valor que es exactamente igual que el valor_buscado.

Formato condicional
Para que el número correspondiente en la matriz se vea de un color de manera automática se utilizó el formato condicional de fórmula.

  1. Selecciona el rango de celdas C6:H37
  2. Clic en Inicio > Formato condicional y en Editar una descripción de regla poner la siguiente fórmula =Y(C$5=$C$3,$B6=$C$2)
  3. Clic en el botón "Formato" y selecciona el formato que deseas.
  4. Clic en aceptar en las ventanas que aparecen (deben ser 3) y listo.




El archivo contiene una segunda opción en la cual se utiliza el formato condicional. Ver imagen



Ver calendario de cursos de Excel en Mérida Yucatán



No hay comentarios.:

Publicar un comentario

Gracias por tu comentario.