Buscar en este blog

24 de enero de 2020

Buscar un Texto dentro de otro Texto

Problema a solucionar
Un usuario tiene un archivo con las siguientes tres columnas.



Se desea saber si el texto en la columna Nombre 2 se encuentra en la columna Nombre 1. Si se encuentra poner 1 en al columna  Resultado, en su defecto poner 0.

Funciones utilizadas en este ejemplo
SI, TIPO, BUSCARV y Asteríscos como comodines *
Explicando la función en la celda C2

=SI(TIPO(BUSCARV("*"&B2&"*",A2,1,FALSO))<>16,1,0)
  1. Necesitamos buscar la cadena de texto de la columna Nombre 2  en la columna Nombre 1, pero en ocasiones la cadena de caracteres de la columna Nombre 1 tiene caracteres adicionales.
  2. Para poner hacer la comparación utilizamos asteriscos. Estos sirven como comodines y reemplazan cualquier caracter que se encuentre antes de de cualquier cadena y después de esta. Para poder unirlos a los valores de la celda B2 utilizamos los signos & "*"&B2&"*"
  3. La matriz de búsqueda solo será de una fila y una columna A2.
  4. Necesitamos el valor de la columna 1
  5.  FALSO, este argumento obliga a excel a buscar considencia exacta, si no la encuentra poner #N/D (para excel #N/D es considerado un error)
  6. Toda la función BUSCARV la anidamos en la función TIPO. TIPO devuelve el tipo de valor resultado. El valor devuelto se convierte en parte de la prueba lógica de SI la cual hace el siguiente análisis; "si el valor devuelto es diferente a un error (Tipo 16 es un error) entonces la función devuelve 1, en su defecto devuelve 0".
  7. Ahora solo resta copiar la fórmula en las demás celdas hacia abajo.
Gracias por visitar mi blog de Excel. ¿Necesitas un Curso de Excel? Mándame un mensaje o correo.


No hay comentarios.:

Publicar un comentario

Gracias por tu comentario.