Buscar en este blog

18 de enero de 2021

Números y Precios Terminados en 9 en Excel - Versión 2

 Precios con la unidad terminada en 9 y en 9.99

En un artículo anterior les mostré como hacer que un número termine en 99 con los decimales originales y sin decimales originales. En esta ocasión les voy a mostrar como cambiar un número de tal manera que su unidad siempre termine en 9.00 y en 9.99

Nota: Este es un caso real que un alumno me presentó

SOLUCIÓN

Caso 1.- Se necesita la unidad termine en 9 y sin decimales



Explicación Caso 1
La función =SI(B3<1,9,(B3-RESIDUO(B3,10))+9) hace lo siguiente. 
=SI(B3<1,9 Esta sección analiza si el número es menor a 1, si es menor a uno pondrá 9, si no, sigue analizando con: (B3-RESIDUO(B3,10))+9). A B3 se le resta el resultado del residuo de B3 entre 10 RESIDUO(B3,10). A esta resta se le suma 9.

Ahora solo resta copiar la fórmula a las demás filas.

Caso 1.- Se necesita la unidad termine en 9.99



Explicación Caso 2

=SI(F3<1,9,(F3-RESIDUO(F3,10))+9.99) Este caso es idéntico al anterior con el detalle que a la resta del número original menos el residuo se le suma 9.99

¿Necesitas Aprender Excel Avanzado?


Aprende Excel Avanzado desde cualquier parte del Mundo en 4 sesiones por videoconferencia por Zoom y Moodle. Visita el siguiente enlace https://www.capacitateexcel.com/p/excel-avanzado.html